Thursday, May 14, 2015

Lab 15 Administrative Distance

Objectives


  • To understand administrative distances for routing protocols
  • To understand that there will be different best path with different routing protocosl

Default administrative distance (The AD is the lower, the priority is the higher)
Route SourceDefault Distance Values
Connected interface0
Static route1
Enhanced Interior Gateway Routing Protocol (EIGRP) summary route5
External Border Gateway Protocol (BGP)20
Internal EIGRP90
IGRP100
OSPF110
Intermediate System-to-Intermediate System (IS-IS)115
Routing Information Protocol (RIP)120
Exterior Gateway Protocol (EGP)140
On Demand Routing (ODR)160
External EIGRP170
Internal BGP200
Unknown*255
255 will never be used.

Topology


Basic Setting

IPs for computers and routers have been set up.

Requirements

Configure RIP, and check routing table on Router3
Configure EIGRP, and check the routing table again on Router3.
Setup RIP

On Router3

Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.1.0
Router(config-router)#version 2

On Router0

Router(config)#router rip
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#version 2

On Router1

Router#conf t
Router(config)#router rip
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.4.0
Router(config-router)#version 2

On Router2

Router#conf t
Router(config)#router rip
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.2.0
Router(config-router)#version 2
Check routing table on Router3
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial2/0
R 192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:15, Serial2/0
R 192.168.3.0/24 [120/2] via 192.168.1.2, 00:00:15, Serial2/0
            [120/2] via 192.168.5.1, 00:00:00, FastEthernet1/0
R 192.168.4.0/24 [120/1] via 192.168.5.1, 00:00:00, FastEthernet1/0
C 192.168.5.0/24 is directly connected, FastEthernet1/0
Two routes to 192.168.3.0/24 will be observed, this is because RIP is based on hops to determine the best path.

Set up EIGRP

On Router3

Router#confi t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router eigrp 10
Router(config-router)#net
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.5.0

On Router0

Router(config)#router eigrp 10
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#

On Router1

Router(config)#router eigrp 10
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.5.0

On Router2

Router(config)#route eigrp 10
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.4.0
Router(config-router)#
Check routing table on Router3 again
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial2/0
D 192.168.2.0/24 [90/21024000] via 192.168.1.2, 00:04:06, Serial2/0
D 192.168.3.0/24 [90/20517120] via 192.168.5.1, 00:00:41, FastEthernet1/0
D 192.168.4.0/24 [90/20514560] via 192.168.5.1, 00:00:41, FastEthernet1/0
C 192.168.5.0/24 is directly connected, FastEthernet1/0
Router#
There is only one route to 192.168.3.0/24 left. The route based on RIP is gone becase RIP has a lower priority than EIGRP.

Router#show ip eigrp topology
IP-EIGRP Topology Table for AS 10
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 192.168.0.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 20512000
via Connected, Serial2/0
P 192.168.5.0/24, 1 successors, FD is 28160
via Connected, FastEthernet1/0
P 192.168.2.0/24, 1 successors, FD is 21024000
via 192.168.1.2 (21024000/20512000), Serial2/0
via 192.168.5.1 (21026560/21024000), FastEthernet1/0
P 192.168.3.0/24, 1 successors, FD is 20517120
via 192.168.5.1 (20517120/20514560), FastEthernet1/0
via 192.168.1.2 (4294967295/20514560), Serial2/0
P 192.168.4.0/24, 1 successors, FD is 20514560
via 192.168.5.1 (20514560/20512000), FastEthernet1/0
Router#
Two routes to 192.168.3.0/24 are listed, and these are two best routes, because EIGRP uses bandwidth and delay to determine the best path.
One of the route is the best path, and the other is backup route. When the best path is not available, backup route will be used immediately. This is why EIGRP has a faster convergence.

Add a static route

On Route3

Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.2 ?
<1-255> Distance metric for this route
<cr>
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.2
Router#show ip route
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial2/0
D 192.168.2.0/24 [90/21024000] via 192.168.1.2, 00:13:52, Serial2/0
S 192.168.3.0/24 [1/0] via 192.168.1.2
D 192.168.4.0/24 [90/20514560] via 192.168.5.1, 00:10:27, FastEthernet1/0
C 192.168.5.0/24 is directly connected, FastEthernet1/0
Static route has a higher priority than EIGRP, therefore route to 192.168.3.0/24 based on EIGRP is no availabel any more.

Show all IP protocols on a router

Router#show ip protocols
Routing Protocol is "eigrp 10 "
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 10
Automatic network summarization is in effect
Automatic address summarization:
Maximum path: 4
Routing for Networks:
192.168.0.0
192.168.1.0
192.168.5.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 90 517117
192.168.5.1 90 724309
Distance: internal 90 external 170
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 1 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
FastEthernet1/0 2 2
Serial2/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
192.168.0.0
192.168.1.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 120 00:00:17
192.168.5.1 120 00:00:21
Distance: (default is 120)
Router#
Summary: a router determines the route to be used based on priority (administrative distance).

No comments :

Post a Comment