Friday, May 15, 2015

Lab 27 Routing between Access layer and Distribution Layer

Objective


  • To configure VLAN routing for a layer 3 switch.

Topology


Setting

PC0 and PC2 ar in VLAN1, and PC1 and PC3 are in VLAN2.
Gig1/1 on every access layer is connected to distribution layer.
Distribution layer switch has routing function
IPs for computers have been set up.

Requirments

  • Configure the link between switches as trunk
  • Configure distribution layer switch to enable routing between VLAN1 and VLAN2.

Steps

On Switch1

Switch>en
Switch#confi t
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#int fastEthernet 0/2
Switch(config-if)#switchport access vlan 2
Switch(config)#int gigabitEthernet 1/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#

On Switch2

Switch>en
Switch#confi t
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#int fastEthernet 0/2
Switch(config-if)#switchport access vlan 2
Switch(config)#int gigabitEthernet 1/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#

On Switch0

Switch>en
Switch#confi t
Switch(config)#vlan 2
Switch(config)#interface gigabitEthernet 0/1
Switch(config)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#interface gigabitEthernet 0/2
Switch(config)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.0.1 255.255.255.0
Switch(config-if)#no sh
Switch(config-if)#exit
Switch(config)#interface vlan 2
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no sh
Switch(config-if)#

On PC3, ping PC0

PC>ping 192.168.0.2
Pinging 192.168.0.2 with 32 bytes of data:
Reply from 192.168.0.2: bytes=32 time=19ms TTL=127
Reply from 192.168.0.2: bytes=32 time=17ms TTL=127
Reply from 192.168.0.2: bytes=32 time=18ms TTL=127
Reply from 192.168.0.2: bytes=32 time=15ms TTL=127
Ping statistics for 192.168.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 15ms, Maximum = 19ms, Average = 17ms
PC>

Lab 26 Routing For VLANs In A Building

Objective

  • Configure trunk to achieve routing among VLANs

Topology


Setting

For better safety and easy troubleshooting, 4 VLANS are set up based on departments. The VLAN 4 is used for servers, and all servers have 1000M Ethernet interface.
IPs for computers have been set up, and the gateway for each network segment is the first available IP.

Requirments

  • Three VLANs should be created on 3 access layer switches, and assign ports to VLANs as shown in the figure.
  • Configre trunk between distribution and access switches
  • Configure Routing between VLANs

Steps

On Switch7

Switch>en
Switch#config t
Switch(config)#vlan 2
Switch(config-vlan)#ex
Switch(config)#vlan 3
Switch(config-vlan)#ex
Switch(config)#interface fastEthernet 1/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#ex
Switch(config)#interface fastEthernet 2/1
Switch(config-if)#switchport access vlan 3
Switch(config)#interface gigabitEthernet 6/1
Switch(config-if)#switchport mode trunk

On Switch2

Switch>en
Switch#config t
Switch(config)#vlan 2
Switch(config-vlan)#ex
Switch(config)#vlan 3
Switch(config-vlan)#ex
Switch(config)#interface fastEthernet 1/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#ex
Switch(config)#interface fastEthernet 2/1
Switch(config-if)#switchport access vlan 3
Switch(config-if)#ex
Switch(config)#interface gigabitEthernet 6/1
Switch(config-if)#switchport mode trunk

On Switch1

Switch>en
Switch#config t
Switch(config)#vlan 3
Switch(config-vlan)#ex
Switch(config)#vlan 2
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#interface gigabitEthernet 0/2
Switch(config-if)#switchport mode trunk
Switch(config-if)#ex
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport access vlan 4
Switch(config-if)#interface fastEthernet 0/2
Switch(config-if)#switchport access vlan 4
Switch(config-if)#ex

Set up VLAN interface for routing 

Switch(config)#interface vlan 1
Switch(config-if)#ip address 172.16.0.1 255.255.0.0
Switch(config-if)#no shut
Switch(config-if)#interface vlan 2
Switch(config-if)#ip address 172.17.0.1 255.255.0.0
Switch(config-if)#interface vlan 3
Switch(config-if)#ip address 172.18.0.1 255.255.0.0
Switch(config-if)#interface vlan 4
Switch(config-if)#ip address 172.19.0.1 255.255.0.0
Switch(config-if)#ex

Test

VLAN4 PC pings VLAN1 PC.

SERVER>ping 172.16.0.2

Pinging 172.16.0.2 with 32 bytes of data:

Reply from 172.16.0.2: bytes=32 time=1ms TTL=127
Reply from 172.16.0.2: bytes=32 time=0ms TTL=127
Reply from 172.16.0.2: bytes=32 time=0ms TTL=127
Reply from 172.16.0.2: bytes=32 time=0ms TTL=127

Ping statistics for 172.16.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

SERVER>

VLAN4 PC pings VLAN2 PC.

SERVER>ping 172.17.0.2

Pinging 172.17.0.2 with 32 bytes of data:

Reply from 172.17.0.2: bytes=32 time=0ms TTL=127
Reply from 172.17.0.2: bytes=32 time=0ms TTL=127
Reply from 172.17.0.2: bytes=32 time=0ms TTL=127
Reply from 172.17.0.2: bytes=32 time=0ms TTL=127

Ping statistics for 172.17.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

VLAN4 PC ping VLAN3 PC.

SERVER>ping 172.18.0.2

Pinging 172.18.0.2 with 32 bytes of data:

Reply from 172.18.0.2: bytes=32 time=0ms TTL=127
Reply from 172.18.0.2: bytes=32 time=0ms TTL=127
Reply from 172.18.0.2: bytes=32 time=0ms TTL=127
Reply from 172.18.0.2: bytes=32 time=0ms TTL=127

Ping statistics for 172.18.0.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

Lab 25 VTP

Objective

  • To learn how to configure VTP domain on switches
  • To understand the function of VTP domain.

Topology


Setting

PC0 and PC2 are in VLAN1, and PC1 and PC3 are in VLAN2.
The two Gig1/1 ports  on access layer switches are connected to the distribution layer switch.
The distribution layer switch has routing function.
IPs for computers have been configured.

Requirements

  • Configure a VTP Domain
  • Configure VTP Clients
  • Configure the VTP server
  • Configure VTP password

Steps

On Switch1

Switch(config)#interface gigabitEthernet 1/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#vtp domain office1
Changing VTP domain name from NULL to office1
Switch(config)#vtp password aaa
Switch(config)#vtp mode client
Setting device to VTP CLIENT mode.
Switch(config)#

On Switch2

Switch#confi t
Switch(config)#interface gigabitEthernet 1/1
Switch(config-if)#switchport mode trunk
Switch(config)#vtp domain office1
Changing VTP domain name from NULL to office1
Switch(config)#vtp mode client
Setting device to VTP CLIENT mode.
Switch(config)#vtp password aaa
Setting device VLAN database password to aaa
Switch(config) #

On Switch0

Switch#confi t
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#interface gigabitEthernet 0/2
Switch(config-if)#switchport mode trunk
Switch(config)#vtp domain office1
Changing VTP domain name from NULL to office1
Switch(config)#vtp password aaa
Switch(config)#vtp mode server
Device mode already VTP SERVER.
Switch(config)#

Test VTP

On Switch0

Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#

On Switch

Switch#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
            Fa0/5, Fa0/6, Fa0/7, Fa0/8
            Fa0/9, Fa0/10, Fa0/11, Fa0/12
            Fa0/13, Fa0/14, Fa0/15, Fa0/16
            Fa0/17, Fa0/18, Fa0/19, Fa0/20
            Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig1/2
2 VLAN0002 active
3 VLAN0003 active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

Lab 24 Spanning Tree

Objective


  • To understand spanning tree protocol11

Topology


Basic Setting

This is a LAN for a building, and two distribution layer switches are used for redundancy.

Requirements

  • Check current root bridge
  • Manually assign root switch.

Steps

On Switch10

Switch#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
   Address 0002.4A63.C9B6
   This bridge is the root
   Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
   Address 0002.4A63.C9B6
   Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
   Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1 Desg FWD 19 128.1 P2p
Fa1/1 Desg FWD 19 128.2 P2p
Fa2/1 Desg FWD 19 128.3 P2p
Gi5/1 Desg FWD 4 128.6 P2p
Gi6/1 Desg FWD 4 128.7 P2p
Gi7/1 Desg FWD 4 128.8 P2p
Gi8/1 Desg FWD 4 128.9 P2p
Switch#

On Switch11

Switch(config)#spanning-tree vlan 1 priority 4096

Check network status again


On Switch11

Switch#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
     Address 00E0.F780.208C
     This bridge is the root
     Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)
     Address 00E0.F780.208C
     Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
     Aging Time 20
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi8/1 Desg FWD 4 128.9 P2p
Gi7/1 Desg FWD 4 128.8 P2p
Gi6/1 Desg FWD 4 128.7 P2p
Gi5/1 Desg FWD 4 128.6 P2p
Switch#

Lab 23 Layer 3 switch

Objective

  • To configure routing between VLANS on a layer 3 switch

Topology


Basic setting

Layer 3 switch

Requirments

  • Configure routing between VLANs
  • Set Fa0/2 to VLAN2
  • Set up VLAN1
  • Set up VLAN2

Steps

ON Multilayer Switch0

Switch(config)#ip routing  // enable routing
Switch(config)#vlan 2
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport access vlan 2
Switch(config-if)#
Switch(config-vlan)#exit
Switch(config)#interface vlan 1
Switch(config-if)#ip address 10.0.0.1 255.0.0.0
Switch(config-if)#int vlan 2
Switch(config-if)#ip address 11.0.0.1 255.0.0.0

On PC1, test connectivity to PC0

PC>ping 10.0.0.2
Pinging 10.0.0.2 with 32 bytes of data:
Request timed out.
Reply from 10.0.0.2: bytes=32 time=8ms TTL=127
Reply from 10.0.0.2: bytes=32 time=10ms TTL=127
Reply from 10.0.0.2: bytes=32 time=5ms TTL=127
Ping statistics for 10.0.0.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 5ms, Maximum = 10ms, Average = 7ms
PC>


Lab 22 Routing between Vlans

Objective

  • To configure routing between VLANs

Topology


Basic setting

  • PC0 is connected to Fa0/1 on the switch
  • PC1 is connected to Fa0/2 on the switch
  • IPs have been set up
  • The router's Fa0/0 is connected to Fa0/10 on the switch , and the Fa0/10 on the switch is in VLAN 1.
  • The router's Fa1/0 is connected to Fa0/4 on switch, and the Fa0/4 on the switch is in VLAN 2.

Requirments

Configure the router's F0/0 with the Ip 192.168.0.1 255.255.255.0
Configure the router's F1/0 with the Ip 192.168.1.1 255.255.255.0
Con figure the PC1 with IP 192.168.1.2 255.255.255.0 and the default gateway 192.168.1.1

Steps

On PC1


On the Router0

Router>en
Router#confi t
Router(config)#int fastEthernet 0/0
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#int f1/0
Router(config-if)#ip add
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no sh

PC1 pings PC0

PC>ping 192.168.0.2
Pinging 192.168.0.2 with 32 bytes of data:
Request timed out.
Reply from 192.168.0.2: bytes=32 time=16ms TTL=127
Reply from 192.168.0.2: bytes=32 time=16ms TTL=127
Reply from 192.168.0.2: bytes=32 time=17ms TTL=127
Ping statistics for 192.168.0.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 16ms, Maximum = 17ms, Average = 16ms
PC>

Thursday, May 14, 2015

Lab 21 Check Mac Table

Objective

To understand the mapping between MACs and ports

Topology


Basic Setting

A HUB and a switch are connected in IP segment of 192.168.0.0/24 and IPs for computers are assigned by DHCP.

Requirement

Check Mac table on the switch.

Steps

On Switch0

Switch#show mac-address-table
Mac Address Table
-------------------------------------------
Vlan Mac Address Type Ports
---- ----------- -------- -----
: Mac table is empty.At the beginning, the switch does not have the mapping between ports and MACs.

On PC2

PC>ping 192.168.0.11
Pinging 192.168.0.11 with 32 bytes of data:
Reply from 192.168.0.11: bytes=32 time=8ms TTL=128
Reply from 192.168.0.11: bytes=32 time=9ms TTL=128
Reply from 192.168.0.11: bytes=32 time=9ms TTL=128
Reply from 192.168.0.11: bytes=32 time=8ms TTL=128
Ping statistics for 192.168.0.11:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 8ms, Maximum = 9ms, Average = 8ms

PC>ping 192.168.0.12
Pinging 192.168.0.12 with 32 bytes of data:
Reply from 192.168.0.12: bytes=32 time=7ms TTL=128
Reply from 192.168.0.12: bytes=32 time=8ms TTL=128
Reply from 192.168.0.12: bytes=32 time=9ms TTL=128
Reply from 192.168.0.12: bytes=32 time=10ms TTL=128
Ping statistics for 192.168.0.12:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 7ms, Maximum = 10ms, Average = 8ms

PC>ping 192.168.0.13
Pinging 192.168.0.13 with 32 bytes of data:
Reply from 192.168.0.13: bytes=32 time=21ms TTL=128
Reply from 192.168.0.13: bytes=32 time=10ms TTL=128
Reply from 192.168.0.13: bytes=32 time=11ms TTL=128
Reply from 192.168.0.13: bytes=32 time=9ms TTL=128
Ping statistics for 192.168.0.13:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 9ms, Maximum = 21ms, Average = 12ms

PC>ping 192.168.0.14
Pinging 192.168.0.14 with 32 bytes of data:
Reply from 192.168.0.14: bytes=32 time=20ms TTL=128
Reply from 192.168.0.14: bytes=32 time=11ms TTL=128
Reply from 192.168.0.14: bytes=32 time=11ms TTL=128
Reply from 192.168.0.14: bytes=32 time=10ms TTL=128
Ping statistics for 192.168.0.14:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 10ms, Maximum = 20ms, Average = 13ms
PC>
After these pings, the switch learnt the MACs.
Check MAC table again on the Switch0
Switch#show mac-address-table
Mac Address Table
-------------------------------------------
Vlan Mac Address Type Ports
---- ----------- -------- -----
1 0000.0c7c.7e49 DYNAMIC Fa0/1
1 0001.63c6.e338 DYNAMIC Fa0/5
1 0030.a336.362b DYNAMIC Fa0/4
1 0030.a3e4.e4c6 DYNAMIC Fa0/4
1 0090.0cd7.65c8 DYNAMIC Fa0/2
1 00d0.ffce.0eb4 DYNAMIC Fa0/3
Note: you can find that Fa02/4 has 2 MACs, because this port is connected to a HUB which is connected to 2 PCs.

Lab 20 Test vlan

Objective

To understand VLAN.

Topology


Basic Setting

  • PC0 is connected to Fa0/1
  • PC1 is connected to Fa0/2.
  • IPs have been set up.

Requirements

  • Create VLAN2.
  • Assign Fa0/2 to VLAN2.

Steps

On PC1

PC>ping 192.168.0.2
Pinging 192.168.0.2 with 32 bytes of data:
Reply from 192.168.0.2: bytes=32 time=9ms TTL=128
Reply from 192.168.0.2: bytes=32 time=9ms TTL=128
Reply from 192.168.0.2: bytes=32 time=7ms TTL=128
Reply from 192.168.0.2: bytes=32 time=8ms TTL=128
Ping statistics for 192.168.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 7ms, Maximum = 9ms, Average = 8ms
PC>
All ports on the switch are in the VLAN1,So all the ports can communicated as long as they have IPs in the same segment.

On Switch0

Switch#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig1/1, Gig1/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1
Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
1002 enet 101002 1500 - - - - - 0 0
1003 enet 101003 1500 - - - - - 0 0
1004 enet 101004 1500 - - - - - 0 0
1005 enet 101005 1500 - - - - - 0 0
Switch#
All ports are in the default VLAN.

Create VLAN2

Switch#confi t
Switch(config)#vlan
Switch(config)#vlan 2
Switch(config-vlan)#
             Note: to delete VLAN Switch(config)#no vlan 2

Assign Fa0/2 – 5 to VLAN2

Switch(config-vlan)#exit
Switch(config)#interface range fastEthernet 0/2 - 5
Switch(config-if-range)#switchport access vlan 2
Switch(config-if-range)#

Show VLAN info

Switch#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig1/1, Gig1/2
2 VLAN0002 active Fa0/2, Fa0/3, Fa0/4, Fa0/5
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1
Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
2 enet 100002 1500 - - - - - 0 0
1002 enet 101002 1500 - - - - - 0 0
1003 enet 101003 1500 - - - - - 0 0
1004 enet 101004 1500 - - - - - 0 0
1005 enet 101005 1500 - - - - - 0 0
Switch#
Fa0/2,Fa0/3, Fa0/4 and Fa0/5 are in VLAN2.

On PC1

PC>ping 192.168.0.2
Pinging 192.168.0.2 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 192.168.0.2:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
PC>
Computers in different VLANs can not communicate.

Lab 19 Router On A Stick

Objective

To configure routing between vlans.

Topology


Basic Setting

  • PC0 is connected to Fa0/1.
  • PC1 is connected to Fa0/2.
  • IPs have been configured.
  • The router's G6/1 is connected to G1/1 on the switch.

Requirements

  • Enable trunk on G1/1 on the switch.
  • Create subinterfaces on G6/0 of the router.
  • On G6/0.1, the IP is configured as 192.168.0.1 255.255.255.0, and this will be the gateway for VLAN1.
  • The IP for G6/0.2 should be configured as 192.168.1.1 255.255.255.0, and this will be the gateway for VLAN2.

Steps

On Router1

Router>en
Router#confi t
Router(config)#interface gigabitEthernet 6/0
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#interface gigabitEthernet 6/0.1   // go to subinterface
Router(config-subif)#encapsulation dot1Q 1  // set this subinterface as the gateway for VLAN1.
Router(config-subif)#ip address 192.168.0.1 255.255.255.0
Router(config-subif)#no sh
Router(config-subif)#exit
Router(config)#interface gigabitEthernet 6/0.2
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#encapsulation d
Router(config-subif)#encapsulation dot1Q 2 // set this as the gateway for VLAN2.
Router(config-subif)#no sh

Check IPs for sub-interfaces

Router#show int g6/0.1

GigabitEthernet6/0.1 is up, line protocol is up (connected)
  Hardware is PQUICC_FEC, address is 00d0.ba64.77ea (bia 00d0.ba64.77ea)
  Internet address is 192.168.0.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID 1
  ARP type: ARPA, ARP Timeout 04:00:00,
  Last clearing of "show interface" counters never

Router#show int g6/0.2

GigabitEthernet6/0.2 is up, line protocol is up (connected)
  Hardware is PQUICC_FEC, address is 00d0.ba64.77ea (bia 00d0.ba64.77ea)
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID 2
  ARP type: ARPA, ARP Timeout 04:00:00,
  Last clearing of "show interface" counters never

On Switch0

Switch>en
Switch#confi t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int
Switch(config)#interface gigabitEthernet 1/1
Switch(config-if)#switchport mode trunk // set mode to Trunk

Ping PC0 from PC1

PC>ping 192.168.0.2
Pinging 192.168.0.2 with 32 bytes of data:
Reply from 192.168.0.2: bytes=32 time=17ms TTL=127
Reply from 192.168.0.2: bytes=32 time=17ms TTL=127
Reply from 192.168.0.2: bytes=32 time=15ms TTL=127
Reply from 192.168.0.2: bytes=32 time=16ms TTL=127
Ping statistics for 192.168.0.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 15ms, Maximum = 17ms, Average = 16ms
Summary: Subinterfaces,created on the G Ethernet interface which is connected to the trunk port on a switch, can be used for routing for different VLANS on a switch.

Lab 18 OSPF Multiple Areas

Objective

To be able to configure OSPF in an environment with multiple areas

Topology


Basic Setting

IPs for computers and routers have been set up.
Requirements
Configure OSPF in are 0, are1 and area2.

Steps

On Route5

Router>en
Router#config t
Router(config)#router ospf 1
Router(config-router)#network 172.16.0.0 0.0.255.255 area 1

On Route6

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 172.16.0.0 0.0.255.255 area 1

On boundary router (Router 2)

Router(config)#router ospf 1
Router(config-router)#network 172.16.0.0 0.0.0.255 area 1
Router(config-router)#network 192.168.0.0 0.0.0.3 area 0

On Router0

Router#config t
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.255 area 0

On Router1

Router#config t
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.255 area 0
Router(config-router)#

On Router4

Router>en
Router#config t
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.255 area 0

On Router3

Router(config)#route ospf 1
Router(config-router)#network 192.168.0.0 0.0.255.255 area 0         // for 2 interfaces
Router(config-router)#

On Router7

Router(config)#router ospf 1
Router(config-router)#network 192.168.0.20 0.0.0.3 area 0
Router(config-router)#network 10.0.0.0 0.0.0.255 area 2

On Router 9

Router#config t
Router(config)#router ospf 1
Router(config-router)#network 10.0.0.0 0.0.255.255 area 2

On Router 10

Router#config t
Router(config)#router ospf 1
Router(config-router)#network 10.0.0.0 0.0.255.255 area 2

Test OSPF

On Router6

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA 10.0.0.0/30 [110/4686] via 172.16.0.9, 00:02:11, Serial2/0
O IA 10.0.0.4/30 [110/4686] via 172.16.0.9, 00:02:11, Serial2/0
O IA 10.0.0.8/30 [110/5467] via 172.16.0.9, 00:02:11, Serial2/0
O IA 10.0.1.0/24 [110/4687] via 172.16.0.9, 00:02:11, Serial2/0
O IA 10.0.2.0/24 [110/4687] via 172.16.0.9, 00:02:11, Serial2/0
172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 172.16.0.0/30 [110/1562] via 172.16.0.5, 00:02:31, Serial3/0
[110/1562] via 172.16.0.9, 00:02:31, Serial2/0
C 172.16.0.4/30 is directly connected, Serial3/0
C 172.16.0.8/30 is directly connected, Serial2/0
O 172.16.1.0/24 [110/782] via 172.16.0.5, 00:02:31, Serial3/0
C 172.16.2.0/24 is directly connected, FastEthernet0/0
192.168.0.0/30 is subnetted, 6 subnets
O IA 192.168.0.0 [110/1562] via 172.16.0.9, 00:02:31, Serial2/0
O IA 192.168.0.4 [110/2343] via 172.16.0.9, 00:02:21, Serial2/0
O IA 192.168.0.8 [110/3124] via 172.16.0.9, 00:02:11, Serial2/0
O IA 192.168.0.12 [110/2343] via 172.16.0.9, 00:02:21, Serial2/0
O IA 192.168.0.16 [110/3124] via 172.16.0.9, 00:02:11, Serial2/0
O IA 192.168.0.20 [110/3905] via 172.16.0.9, 00:02:11, Serial2/0
Router#

On PC0, tracert PC2

PC>tracert 10.0.0.2
Tracing route to 10.0.0.2 over a maximum of 30 hops:
1 8 ms 6 ms 7 ms 172.16.2.1
2 12 ms 14 ms 12 ms 172.16.0.9
3 18 ms 15 ms 19 ms 192.168.0.2
4 21 ms 21 ms 20 ms 192.168.0.6
5 32 ms 22 ms 25 ms 192.168.0.10
6 29 ms 29 ms 25 ms 192.168.0.22
7 28 ms 33 ms 24 ms 10.0.0.2
Trace complete.
PC>

Lab 17 OSPF Single Area

Objective

To be able to configure OSPF in single area network environment.

Topology



Basic Setting

IPs for computers and routers have been set up.

Requirements


  • Configure OSPF in area 0
  • Check the routing table.
  • Check the convergence for OSPF.

Steps

On Router2

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.3 area 0
Router(config-router)#network 172.16.0.0 0.0.255.255 area 0
Router(config-router)#
OR
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.1 0.0.0.0 area 0
Router(config-router)#network 172.16.0.1 0.0.0.0 area 0
Router(config-router)#

On Route0

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.3 area 0
Router(config-router)#network 192.168.0.4 0.0.0.3 area 0
Router(config-router)#network 192.168.0.12 0.0.0.3 area 0
Router(config-router)#ex

On Router1

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.255 area 0

On Router4

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.255 area 0
Router(config-router)#network 172.18.0.0 0.0.255.255 area 0

On Router3

Router>en
Router#config t
Router(config)#router ospf 1
Router(config-router)#network 192.168.0.0 0.0.0.255 area 0
Router(config-router)#network 172.17.0.0 0.0.255.255 area 0
Router(config-router)#

Check the routing table

On Router3

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
 i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
 * - candidate default, U - per-user static route, o - ODR
 P - periodic downloaded static route
Gateway of last resort is not set
O 172.16.0.0/16 [110/1563] via 192.168.0.13, 00:01:15, Serial2/0
C 172.17.0.0/16 is directly connected, FastEthernet0/0
O 172.18.0.0/16 [110/782] via 192.168.0.17, 00:01:15, Serial3/0
192.168.0.0/30 is subnetted, 5 subnets
O 192.168.0.0 [110/1562] via 192.168.0.13, 00:01:15, Serial2/0
O 192.168.0.4 [110/1562] via 192.168.0.13, 00:01:15, Serial2/0
O 192.168.0.8 [110/1562] via 192.168.0.17, 00:01:15, Serial3/0
C 192.168.0.12 is directly connected, Serial2/0
C 192.168.0.16 is directly connected, Serial3/0
Router#

Check OSPF neighbors

Router#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.0.13 1 FULL/- 00:00:39 192.168.0.13 Serial2/0
192.168.0.17 1 FULL/- 00:00:35 192.168.0.17 Serial3/0
Router#

Check OSPF database

Router#show ip ospf database
OSPF Router with ID (192.168.0.18) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
192.168.0.1 192.168.0.1 673 0x80000005 0x0082b6 3
192.168.0.9 192.168.0.9 317 0x80000004 0x004015 4
192.168.0.17 192.168.0.17 219 0x80000005 0x00dc82 5
192.168.0.13 192.168.0.13 214 0x80000006 0x00fbd0 6
192.168.0.18 192.168.0.18 200 0x80000005 0x0093be 5

Test OSPF convergence speed

On PC0

PC>tracert 172.17.0.2
Tracing route to 172.17.0.2 over a maximum of 30 hops:
1 6 ms 8 ms 7 ms 172.16.0.1
2 12 ms 11 ms 11 ms 192.168.0.2
3 13 ms 18 ms 15 ms 192.168.0.14
4 25 ms 28 ms 29 ms 172.17.0.2
Trace complete.
PC>
Package path : Router2=>Router0=>Router3


On Router3

Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface serial 2/0
Router(config-if)#shutdown

On PC0

PC>tracert 172.17.0.2
Tracing route to 172.17.0.2 over a maximum of 30 hops:
1 9 ms 6 ms 7 ms 172.16.0.1
2 15 ms 11 ms 13 ms 192.168.0.2
3 14 ms 14 ms 16 ms 192.168.0.6
4 19 ms 22 ms 15 ms 192.168.0.10
5 26 ms 25 ms 29 ms 192.168.0.18
6 29 ms 30 ms 36 ms 172.17.0.2
Trace complete.
Package path: Router2=>Router0=>Router1=>Router4=>Router3



Lab 16 Turn Off auto-summary for EIGRP


Objective

  • To understand the auto-summary for EIGRP.
  • auto summary at the class boundary.
  • Disable auto summary in a network with discontinuous IP.

Topology


Basic Setting

IPs for computers and routers have been set up.

Requirements

Configure EIGRP on routers, and disable auto summary for discontinuous IPs.

On Router5, 2, 0 and 1

Router(config)#route eigr 10
Router(config-router)#network 172.16.0.0

On Router4 and 3

Router(config)#route eigr 10
Router(config-router)#network 172.16.0.0
Router(config-router)#network 10.0.0.0

On Router6

Router(config)#route eigr 10
Router(config-router)#network 10.0.0.0
Check summary

On Router6

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, Serial3/0
C 10.0.1.0 is directly connected, Serial2/0
D 172.16.0.0/16 [90/20514560] via 10.0.0.1, 00:14:03, Serial3/0
[90/20514560] via 10.0.1.2, 00:13:41, Serial2/0
Router#
For 172.16.0.0/16 there are two routes, which is caused by incorrect summary.
Ping PC0 from Router6
Router#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
..!.!
Success rate is 40 percent (2/5), round-trip min/avg/max = 13/14/15 ms
Router#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
.!.!.
Success rate is 40 percent (2/5), round-trip min/avg/max = 14/16/19 ms
There is package discarding, which is cause yb incorrect summary.

Turn off auto summary for EIGRP

Run these commands on all routers
Router(config)#router e 10
Router(config-router)#no auto-summary
Router(config-router)#

On Router6

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.0.0.0/8 [90/21024000] via 10.0.0.1, 00:01:20, Serial3/0
[90/21024000] via 10.0.1.2, 00:01:03, Serial2/0
C 10.0.0.0/24 is directly connected, Serial3/0
C 10.0.1.0/24 is directly connected, Serial2/0
172.16.0.0/16 is variably subnetted, 11 subnets, 2 masks
D 172.16.0.0/16 is a summary, 00:01:37, Null0
D 172.16.0.0/24 [90/22050560] via 10.0.1.2, 00:00:07, Serial2/0
D 172.16.1.0/24 [90/22048000] via 10.0.1.2, 00:00:28, Serial2/0
D 172.16.2.0/24 [90/21538560] via 10.0.1.2, 00:00:28, Serial2/0
D 172.16.3.0/24 [90/21536000] via 10.0.1.2, 00:00:45, Serial2/0
D 172.16.4.0/24 [90/21026560] via 10.0.1.2, 00:00:45, Serial2/0
D 172.16.5.0/24 [90/21024000] via 10.0.1.2, 00:01:03, Serial2/0
D 172.16.6.0/24 [90/20514560] via 10.0.1.2, 00:01:03, Serial2/0
D 172.16.8.0/24 [90/20514560] via 10.0.0.1, 00:01:20, Serial3/0
D 172.16.9.0/24 [90/21024000] via 10.0.0.1, 00:01:20, Serial3/0
D 172.16.10.0/24 [90/21026560] via 10.0.0.1, 00:01:20, Serial3/0
Router#ping 172.16.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 17/23/27 ms
Router#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 14/16/20 ms
Router#
Note: after disable auto-summary, no summary at class boundaries will be made, and Router 6 can learn routing information for all network segments.

Lab 15 Administrative Distance

Objectives


  • To understand administrative distances for routing protocols
  • To understand that there will be different best path with different routing protocosl

Default administrative distance (The AD is the lower, the priority is the higher)
Route SourceDefault Distance Values
Connected interface0
Static route1
Enhanced Interior Gateway Routing Protocol (EIGRP) summary route5
External Border Gateway Protocol (BGP)20
Internal EIGRP90
IGRP100
OSPF110
Intermediate System-to-Intermediate System (IS-IS)115
Routing Information Protocol (RIP)120
Exterior Gateway Protocol (EGP)140
On Demand Routing (ODR)160
External EIGRP170
Internal BGP200
Unknown*255
255 will never be used.

Topology


Basic Setting

IPs for computers and routers have been set up.

Requirements

Configure RIP, and check routing table on Router3
Configure EIGRP, and check the routing table again on Router3.
Setup RIP

On Router3

Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.1.0
Router(config-router)#version 2

On Router0

Router(config)#router rip
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#version 2

On Router1

Router#conf t
Router(config)#router rip
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.4.0
Router(config-router)#version 2

On Router2

Router#conf t
Router(config)#router rip
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.2.0
Router(config-router)#version 2
Check routing table on Router3
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial2/0
R 192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:15, Serial2/0
R 192.168.3.0/24 [120/2] via 192.168.1.2, 00:00:15, Serial2/0
            [120/2] via 192.168.5.1, 00:00:00, FastEthernet1/0
R 192.168.4.0/24 [120/1] via 192.168.5.1, 00:00:00, FastEthernet1/0
C 192.168.5.0/24 is directly connected, FastEthernet1/0
Two routes to 192.168.3.0/24 will be observed, this is because RIP is based on hops to determine the best path.

Set up EIGRP

On Router3

Router#confi t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router eigrp 10
Router(config-router)#net
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.5.0

On Router0

Router(config)#router eigrp 10
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#

On Router1

Router(config)#router eigrp 10
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.5.0

On Router2

Router(config)#route eigrp 10
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.4.0
Router(config-router)#
Check routing table on Router3 again
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial2/0
D 192.168.2.0/24 [90/21024000] via 192.168.1.2, 00:04:06, Serial2/0
D 192.168.3.0/24 [90/20517120] via 192.168.5.1, 00:00:41, FastEthernet1/0
D 192.168.4.0/24 [90/20514560] via 192.168.5.1, 00:00:41, FastEthernet1/0
C 192.168.5.0/24 is directly connected, FastEthernet1/0
Router#
There is only one route to 192.168.3.0/24 left. The route based on RIP is gone becase RIP has a lower priority than EIGRP.

Router#show ip eigrp topology
IP-EIGRP Topology Table for AS 10
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 192.168.0.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 20512000
via Connected, Serial2/0
P 192.168.5.0/24, 1 successors, FD is 28160
via Connected, FastEthernet1/0
P 192.168.2.0/24, 1 successors, FD is 21024000
via 192.168.1.2 (21024000/20512000), Serial2/0
via 192.168.5.1 (21026560/21024000), FastEthernet1/0
P 192.168.3.0/24, 1 successors, FD is 20517120
via 192.168.5.1 (20517120/20514560), FastEthernet1/0
via 192.168.1.2 (4294967295/20514560), Serial2/0
P 192.168.4.0/24, 1 successors, FD is 20514560
via 192.168.5.1 (20514560/20512000), FastEthernet1/0
Router#
Two routes to 192.168.3.0/24 are listed, and these are two best routes, because EIGRP uses bandwidth and delay to determine the best path.
One of the route is the best path, and the other is backup route. When the best path is not available, backup route will be used immediately. This is why EIGRP has a faster convergence.

Add a static route

On Route3

Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.2 ?
<1-255> Distance metric for this route
<cr>
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.2
Router#show ip route
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Serial2/0
D 192.168.2.0/24 [90/21024000] via 192.168.1.2, 00:13:52, Serial2/0
S 192.168.3.0/24 [1/0] via 192.168.1.2
D 192.168.4.0/24 [90/20514560] via 192.168.5.1, 00:10:27, FastEthernet1/0
C 192.168.5.0/24 is directly connected, FastEthernet1/0
Static route has a higher priority than EIGRP, therefore route to 192.168.3.0/24 based on EIGRP is no availabel any more.

Show all IP protocols on a router

Router#show ip protocols
Routing Protocol is "eigrp 10 "
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 10
Automatic network summarization is in effect
Automatic address summarization:
Maximum path: 4
Routing for Networks:
192.168.0.0
192.168.1.0
192.168.5.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 90 517117
192.168.5.1 90 724309
Distance: internal 90 external 170
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 1 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
FastEthernet1/0 2 2
Serial2/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
192.168.0.0
192.168.1.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
192.168.1.2 120 00:00:17
192.168.5.1 120 00:00:21
Distance: (default is 120)
Router#
Summary: a router determines the route to be used based on priority (administrative distance).

Lab 14 EIGRP

Objectives

  • To learn configure EIGRP in cisco device only networks.

Topology

In this topology, only IPs have been configured.

Basic Setting

IPs for computers and routers have been set up.

Requirements

  • You need to configure EIGRP on routers
  • Check routes based on EIGRP in routing table 
  • Test connectivity
Steps

On Router8

Router#confi t
Router(config)#route eigrp 10
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0

On Router2

Router#confi t
Router(config)#router eigrp 10
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
Router(config-router)#

On Router3

Router#confi t
Router(config)#router eigrp 10
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.3.0
Router(config-router)#

On Router4

Router#confi t
Router(config)#router eigrp 10
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.5.0
Router(config-router)#

On Router5

Router#confi t
Router(config)#router eigrp 10
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.6.0
Router(config-router)#network 192.168.7.0
Router(config-router)#

On Router7

Router#confi t
Router(config)#router eigrp 10
Router(config-router)#network 192.168.8.0
Router(config-router)#network 192.168.7.0
Router(config-router)#

On Router0

Router#confi t
Router(config)#router eigrp10
Router(config-router)#network 192.168.8.0
Router(config-router)#network 192.168.9.0
Router(config-router)#

On Router1

Router#confi t
Router(config)#router eigrp 10
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.9.0
Router(config-router)#

Test configuration 

Routing table on Router8

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
  i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
  * - candidate default, U - per-user static route, o - ODR
  P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, Serial3/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial2/0
D 192.168.3.0/24 [90/21024000] via 192.168.2.2, 00:04:24, Serial2/0
D 192.168.4.0/24 [90/21536000] via 192.168.2.2, 00:03:59, Serial2/0
D 192.168.5.0/24 [90/22048000] via 192.168.2.2, 00:03:35, Serial2/0
D 192.168.6.0/24 [90/22050560] via 192.168.2.2, 00:03:11, Serial2/0
         [90/22050560] via 192.168.0.1, 00:00:53, Serial3/0
D 192.168.7.0/24 [90/22048000] via 192.168.0.1, 00:00:53, Serial3/0
D 192.168.8.0/24 [90/21536000] via 192.168.0.1, 00:00:53, Serial3/0
D 192.168.9.0/24 [90/21024000] via 192.168.0.1, 00:00:56, Serial3/0
Router#
Two routes to 192.168.6.0/24 with equal cost were found, and their AD was 90 and metrics were 22050560.

On Router, show EIGRP interfaces

Router#show ip eigrp interfaces
IP-EIGRP interfaces for process 10
Xmit Queue Mean Pacing Time Multicast
Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 0 0/0 1236 0/10 0 0
Ser2/0 1 0/0 1236 0/10 0 0
Ser3/0 1 0/0 1236 0/10 0 0
Router#

Ping PC1 from PC0

PC>ping 192.168.6.2
Pinging 192.168.6.2 with 32 bytes of data:
Request timed out.
Reply from 192.168.6.2: bytes=32 time=39ms TTL=123
Reply from 192.168.6.2: bytes=32 time=34ms TTL=123
Reply from 192.168.6.2: bytes=32 time=23ms TTL=123
Ping statistics for 192.168.6.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 23ms, Maximum = 39ms, Average = 32ms

Shut down S2/0 on Router3 to mimic network disorder

On Router3

Router#confi t
Router(config)#int serial 2/0
Router(config-if)#shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to dow

Check routing table on Router 8 immediately

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, Serial3/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial2/0
D 192.168.3.0/24 [90/21024000] via 192.168.2.2, 00:01:03, Serial2/0
D 192.168.5.0/24 [90/22560000] via 192.168.0.1, 00:00:10, Serial3/0
D 192.168.6.0/24 [90/22050560] via 192.168.0.1, 00:13:58, Serial3/0
D 192.168.7.0/24 [90/22048000] via 192.168.0.1, 00:13:58, Serial3/0
D 192.168.8.0/24 [90/21536000] via 192.168.0.1, 00:13:58, Serial3/0
D 192.168.9.0/24 [90/21024000] via 192.168.0.1, 00:14:01, Serial3/0
Router#
Only one route to 192.168.6.0/24 was found, which means that EIGRP has a rapid convergence.

Ping PC 1 from PC0

PC>ping 192.168.6.2
Pinging 192.168.6.2 with 32 bytes of data:
Reply from 192.168.6.2: bytes=32 time=34ms TTL=123
Reply from 192.168.6.2: bytes=32 time=30ms TTL=123
Reply from 192.168.6.2: bytes=32 time=31ms TTL=123
Reply from 192.168.6.2: bytes=32 time=33ms TTL=123
Ping statistics for 192.168.6.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 30ms, Maximum = 34ms, Average = 32ms
Then network turn into a stable condition in no time.

Lab 13 RIPv2 for discontinuous IP segments

Objectives

  • To learn the difference between the 2 versions of RIP
  • RIPv1 does not support variable length subnetting and discontinuous subnets
  • RIPv2 supports variable length subnetting and discontinuous subnets
Topology

Basic Setting

IPs for computers and routers have been set up.

Requirements

  • Enable RIP on all routers.
  • Show IP route on Router6 to find potential errors.
  • Upgrade RIP to RIPv2 on all routers.
  • Show IP route on Router 6 again to compare the difference with last show ip route.

Configure RIP

On Router5, 2, 0 and 1

Router(config)#route rip
Router(config-router)#network 172.16.0.0

On Router4 and 3

Router(config)#route rip
Router(config-router)#network 172.16.0.0
Router(config-router)#network 10.0.0.0

On Router6

Router(config)#route rip
Router(config-router)#network 10.0.0.0

show IP route summary

Show IP route on Router 6

Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, Serial3/0
C 10.0.1.0 is directly connected, Serial2/0
R 172.16.0.0/16 [120/1] via 10.0.1.2, 00:00:00, Serial2/0
[120/1] via 10.0.0.1, 00:00:00, Serial3/0
Router#
Two routes to 172.16.0.0/16 were found, but they were incorrect summary.

Ping PC0 from Router6

Router#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
..!.!
Success rate is 40 percent (2/5), round-trip min/avg/max = 13/14/15 ms
Router#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
.!.!.
Success rate is 40 percent (2/5), round-trip min/avg/max = 14/16/19 ms
Packet discarding was found, which was caused by incorrect route summary.

Enable RIPv2

Configure the following setting on all routers

Router(config)#router rip
Router(config-router)#version 2 // upgrade to version 2
Router(config-router)#no auto-summary // turn off auto-summary

On Router6

RRouter#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, Serial3/0
C 10.0.1.0 is directly connected, Serial2/0
172.16.0.0/24 is subnetted, 10 subnets
R 172.16.0.0 [120/4] via 10.0.1.2, 00:00:00, Serial2/0
R 172.16.1.0 [120/3] via 10.0.1.2, 00:00:00, Serial2/0
R 172.16.2.0 [120/3] via 10.0.1.2, 00:00:00, Serial2/0
R 172.16.3.0 [120/2] via 10.0.1.2, 00:00:00, Serial2/0
R 172.16.4.0 [120/2] via 10.0.1.2, 00:00:00, Serial2/0
R 172.16.5.0 [120/1] via 10.0.1.2, 00:00:00, Serial2/0
R 172.16.6.0 [120/1] via 10.0.1.2, 00:00:00, Serial2/0
R 172.16.8.0 [120/1] via 10.0.0.1, 00:00:02, Serial3/0
R 172.16.9.0 [120/1] via 10.0.0.1, 00:00:02, Serial3/0
R 172.16.10.0 [120/2] via 10.0.0.1, 00:00:02, Serial3/0Router#
Router#ping 172.16.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
.!!!! ///Ping 172.16.0.0/24, successful
Success rate is 80 percent (4/5), round-trip min/avg/max = 17/23/27 ms
Router#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
.!!!! ///Ping 172.16.10.0/24, successful
Success rate is 80 percent (4/5), round-trip min/avg/max = 14/16/20 ms
Router#

Lab 12 RIP Lesson B


Objective 

  • To configure RIP in a simple network.
  • To check metrics and administrative distance and for RIP.
  • To check load balance.
  • To understand effect of topology change on RIP


Topology


Basic Setting

IPs for computers and routers have been set up.

Requirements

  • You need to configure routers to use RIP to learn routing tables.
  • You should use Version 2 RIP.
  • You should be able to check routes based on RIP. 
  • Test connectivity
  • Monitor exchange of routing info based on RIP.

Steps

On Router8
Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#version 2

On Router2
Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.2.0
Router(config-router)#network 192.168.3.0
Router(config-router)#version 2
Router(config-router)#

On Router3
Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.3.0
Router(config-router)#version 2
Router(config-router)#

On Router4
Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.4.0
Router(config-router)#network 192.168.5.0
Router(config-router)#version 2
Router(config-router)#

On Router5
Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.6.0
Router(config-router)#network 192.168.7.0
Router(config-router)#version 2
Router(config-router)#

On Router7
Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.8.0
Router(config-router)#network 192.168.7.0
Router(config-router)#version 2
Router(config-router)#

On Router0
Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.8.0
Router(config-router)#network 192.168.9.0
Router(config-router)#version 2
Router(config-router)#

On Router1
Router#confi t
Router(config)#router rip
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.9.0
Router(config-router)#version 2
Router(config-router)#

Test configurations 
Show routing table on Router8
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, Serial3/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial2/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:27, Serial2/0
R 192.168.4.0/24 [120/2] via 192.168.2.2, 00:00:27, Serial2/0
R 192.168.5.0/24 [120/3] via 192.168.2.2, 00:00:27, Serial2/0
R 192.168.6.0/24 [120/4] via 192.168.2.2, 00:00:27, Serial2/0
[120/4] via 192.168.0.1, 00:00:07, Serial3/0
R 192.168.7.0/24 [120/3] via 192.168.0.1, 00:00:07, Serial3/0
R 192.168.8.0/24 [120/2] via 192.168.0.1, 00:00:07, Serial3/0
R 192.168.9.0/24 [120/1] via 192.168.0.1, 00:00:07, Serial3/0
Router#

Ping from PC0 to PC1
PC>ping 192.168.6.2
Pinging 192.168.6.2 with 32 bytes of data:
Request timed out.
Reply from 192.168.6.2: bytes=32 time=39ms TTL=123
Reply from 192.168.6.2: bytes=32 time=34ms TTL=123
Reply from 192.168.6.2: bytes=32 time=23ms TTL=123
Ping statistics for 192.168.6.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 23ms, Maximum = 39ms, Average = 32ms

Shut down S2/0 on Router 3 to mimic a network disorder
On Router3
Router#confi t
Router(config)#int serial 2/0
Router(config-if)#shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to dow

Check routing table on Router8 immediately 
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, Serial3/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial2/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:08, Serial2/0
R 192.168.4.0/24 [120/2] via 192.168.2.2, 00:00:08, Serial2/0
R 192.168.5.0/24 [120/3] via 192.168.2.2, 00:00:08, Serial2/0
R 192.168.6.0/24 [120/4] via 192.168.2.2, 00:00:08, Serial2/0
[120/4] via 192.168.0.1, 00:00:05, Serial3/0
R 192.168.7.0/24 [120/3] via 192.168.0.1, 00:00:05, Serial3/0
R 192.168.8.0/24 [120/2] via 192.168.0.1, 00:00:05, Serial3/0
R 192.168.9.0/24 [120/1] via 192.168.0.1, 00:00:05, Serial3/0
Router#
To 192.168.6.0/24, there are still to routes, Router 8 has not been informed of the network change because of delay.

Ping from PC0 to PC1
PC>ping 192.168.6.2
Pinging 192.168.6.2 with 32 bytes of data:
Reply from 192.168.3.2: Destination host unreachable.
Request timed out.
Reply from 192.168.3.2: Destination host unreachable.
Reply from 192.168.6.2: bytes=32 time=35ms TTL=123
Ping statistics for 192.168.6.2:
Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),
Approximate round trip times in milli-seconds:
Minimum = 16ms, Maximum = 35ms, Average = 68ms
PC>
Network will be instable for a short period.

After a while, on Router8
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.0.0/24 is directly connected, Serial3/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial2/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:00, Serial2/0
R 192.168.4.0/24 is possibly down, routing via 192.168.2.2, Serial2/0
R 192.168.5.0/24 [120/4] via 192.168.0.1, 00:00:23, Serial3/0
R 192.168.6.0/24 [120/4] via 192.168.0.1, 00:00:23, Serial3/0
R 192.168.7.0/24 [120/3] via 192.168.0.1, 00:00:23, Serial3/0
R 192.168.8.0/24 [120/2] via 192.168.0.1, 00:00:23, Serial3/0
R 192.168.9.0/24 [120/1] via 192.168.0.1, 00:00:23, Serial3/0
Router#
There is only one route to 192.168.6.0/24 left.

Wednesday, May 13, 2015

Lab 11 RIP Lesson A

Objective 
  • To configure RIP in a simple network.
  • To check metrics and administrative distance and for RIP.
Topology


Basic Setting

IPs for computers and routers have been set up.

Requirements
  • You need to configure routers to use RIP to learn routing tables.
  • You should use Version 2 RIP.
  • You should be able to check routes based on RIP. 
  • Test connectivity
  • Monitor exchange of routing info based on RIP.
Steps
On Route2
Router#confi t
Router(config)#router rip
Router(config-router)#network 172.16.0.0
Router(config-router)#version 2

On Router3
Router#confi t
Router(config)#router rip
Router(config-router)#network 172.16.0.0
Router(config-router)#version 2
Router(config-router)#

On Router0
Router#confi t
Router(config)#router rip
Router(config-router)#network 172.16.0.0
Router(config-router)#version 2
Router(config-router)#

On Router1
Router#confi t
Router(config)#router rip
Router(config-router)#network 172.16.0.0
Router(config-router)#version 2
Router(config-router)#

Check 
Routing table on Router2
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 6 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
R 172.16.1.0 [120/2] via 172.16.3.2, 00:00:10, Serial2/0
R 172.16.2.0 [120/2] via 172.16.3.2, 00:00:10, Serial2/0
C 172.16.3.0 is directly connected, Serial2/0
R 172.16.4.0 [120/1] via 172.16.3.2, 00:00:10, Serial2/0
R 172.16.5.0 [120/1] via 172.16.3.2, 00:00:10, Serial2/0
Router#

Ping from PC1 to PC0
PC>ping 172.16.1.2
Pinging 172.16.1.2 with 32 bytes of data:
Request timed out.
Reply from 172.16.1.2: bytes=32 time=23ms TTL=125
Reply from 172.16.1.2: bytes=32 time=19ms TTL=125
Reply from 172.16.1.2: bytes=32 time=27ms TTL=125
Ping statistics for 172.16.1.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 19ms, Maximum = 27ms, Average = 23ms
PC>

Ping from PC1 to PC2
PC>ping 172.16.2.2
Pinging 172.16.2.2 with 32 bytes of data:
Request timed out.
Reply from 172.16.2.2: bytes=32 time=20ms TTL=125
Reply from 172.16.2.2: bytes=32 time=25ms TTL=125
Reply from 172.16.2.2: bytes=32 time=23ms TTL=125
Ping statistics for 172.16.2.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 20ms, Maximum = 25ms, Average = 22ms
PC>

Mointor RIP information exchange on Router2
Router#debug ip rip
RIP protocol debugging is on
Router#RIP: received v2 update from 172.16.3.2 on Serial2/0
172.16.1.0/24 via 0.0.0.0 in 2 hops
172.16.2.0/24 via 0.0.0.0 in 2 hops
172.16.4.0/24 via 0.0.0.0 in 1 hops
172.16.5.0/24 via 0.0.0.0 in 1 hops
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (172.16.0.1)
RIP: build update entries
172.16.1.0/24 via 0.0.0.0, metric 3, tag 0
172.16.2.0/24 via 0.0.0.0, metric 3, tag 0
172.16.3.0/24 via 0.0.0.0, metric 1, tag 0
172.16.4.0/24 via 0.0.0.0, metric 2, tag 0
172.16.5.0/24 via 0.0.0.0, metric 2, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial2/0 (172.16.3.1)
RIP: build update entries
172.16.0.0/24 via 0.0.0.0, metric 1, tag 0

Turn off Debug on Router2
Router#undebug all
All possible debugging has been turned off

Lab 10 Static Load Balancing


Objective
To practice load balance with 2 static route for a network segment
Topology

Basic Setting

IPs for PCs and routers as well as static routes have been configured

Requirements
In this lab, we only require network 192.168.1.0/24 and 192.168.6.0/24 can communicate.
You are required to set up 2 static routes to 192.168.6.0/24 on Router8, and 2 static routes to 192.168.1.0/24 on Router 5.
On router 2, 3 and 4, static routes to 192.168.1.0/24 and 192.168.6.0/24 are also required.
On router 1, 0, 7, static routes to 192.168.1.0/24 and 192.168.6.0/24 are also needed.

Steps
On Route2
Router#confi t
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.3.2

On Router3
Router#confi t
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.4.2

On Router4
Router#conf t
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.4.1
Router(config)#ip route 192.168.5.0 255.255.255.0 192.168.5.2

On Router1
Router#confi t
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.0.2
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.9.1

On Router0
Router#confi t
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.9.2
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.8.1

On Router 7
Router#confi t
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.8.2
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.7.1

On Router8, add to routes to 192.168.6.0/24
Router#confi t
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.2.2
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.0.1

On Router5, add to static routes to 192.168.1.0/24
Router#confi t
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.5.1
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.7.2

Test load balance
From PC0 to PC1
PC>ping 192.168.6.2
Pinging 192.168.6.2 with 32 bytes of data:
Reply from 192.168.6.2: bytes=32 time=34ms TTL=123
Reply from 192.168.6.2: bytes=32 time=35ms TTL=123
Reply from 192.168.6.2: bytes=32 time=31ms TTL=123
Reply from 192.168.6.2: bytes=32 time=35ms TTL=123
Ping statistics for 192.168.6.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 31ms, Maximum = 35ms, Average = 33ms

Shut down serial 2/0 on Router 3
Router#confi t
Router(config)#int serial 2/0
Router(config-if)#sh

Ping from PC0 to PC1
PC>ping 192.168.6.2
Pinging 192.168.6.2 with 32 bytes of data:
Reply from 192.168.3.2: Destination host unreachable. // via Router 3
Reply from 192.168.6.2: bytes=32 time=34ms TTL=123 // this route OK
Reply from 192.168.3.2: Destination host unreachable.
Request timed out.
Ping statistics for 192.168.6.2:
Packets: Sent = 4, Received = 1, Lost = 3 (75% loss),
Approximate round trip times in milli-seconds:
Minimum = 16ms, Maximum = 34ms, Average = 71ms
PC>

Lab 9 Default Route - Example B

Objectives:
To reduce entries in routing table using default route.

Topology
Basic Setting
IPs for PCs and routers as well as static routes have been configured.
The second IP in each segment is used for the PC in each segment, and the first IP is used for the Ethernet interface for routers.
For each WAN, left IP is the first IP in the segment, and right IP is the second IP in the segment.

Requirements
Using default routes to reduce entries in routing tables.

Steps
On Route0
Router#confi t
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2

On Router1
Router#configure t
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
Router(config)#ip route 192.168.0.0 255.255.255.0 192.168.1.1

On Router2
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip rou
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.2
Router(config)#ip route 192.168.0.0 255.255.255.0 192.168.2.1
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
or 

The 2 red entries are combined into one entry
Router(config)#ip route 192.168.0.0 255.255.254.0 192.168.2.1

On Router3
Router#conf t
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.1
Router(config)#ip route 192.168.5.0 255.255.255.0 192.168.4.2
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.4.2

On Router4
Router#confi t
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.5.2

On Router5
Router#conf t
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.5.1

Test 
From PC0 to PC1
PC>ping 192.168.6.2
Pinging 192.168.6.2 with 32 bytes of data:
Request timed out.
Reply from 192.168.6.2: bytes=32 time=31ms TTL=122
Reply from 192.168.6.2: bytes=32 time=36ms TTL=122
Reply from 192.168.6.2: bytes=32 time=36ms TTL=122
Ping statistics for 192.168.6.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:

Minimum = 31ms, Maximum = 36ms, Average = 34ms